Ultraleap product compatibility guide

With over ten years of history there are now many generations of hardware products, software releases, tooling and applications in existence which can cause some confusion and questions when you are getting started with hand tracking.

This guide is designed to provide some clarity on these different generations and help you for avoid compatibility issues between different versions of hardware, software, tooling and applications. 

Leap Motion? Ultraleap? Ultrahaptics? What name should I use?

Leap Motion, created in 2013, was the company that created the original Leap Motion Controller and the hand tracking software. In 2019, Leap Motion merged with Ultrahaptics, and the resulting company was renamed to Ultraleap. This article provides some more detail on this.

This guide will still refer to some software version using "Leap Motion" to remain consistent with how these are presented on the Legacy downloads page on the Ultraleap developer's website.

If you're looking for the latest version of Ultraleap's hand tracking, click on this link

API Compatibility

Version Leap API LeapC API OpenXR
Leap Motion 2.x
Leap Motion Orion 3.x
Leap Motion Orion 4.x
Ultraleap Gemini 5.2+ ¹

Operating System Compatibility

Version Windows MacOS Linux Android (XR2 only)
Leap Motion 2.x
Leap Motion Orion 3.x
Leap Motion Orion 4.x
Ultraleap Gemini 5.2+ ²

Hardware compatibility

Version Leap Motion Controller SIR-170/3Di Leap Motion Controller 2
Leap Motion 2.x
Leap Motion Orion 3.x
Leap Motion Orion 4.x
Ultraleap Gemini 5.2+ ³

Programming languages support

This table does not cover any community-made bindings, and only includes languages that are officially supported by Ultraleap.

Because language support is tied to which API is supported, language support is listed per API instead of per SDK version.

Version C/C++ C# Python Java JavaScript
Leap API
LeapC API

(via Python binding)

The updated Python bindings for Gemini V5 and the LeapC API can be found here.

If you wish to use a coding language that isn't officially supported we want to hear from you, please let us know here.

Supported game engines

Leap Motion Core Assets for the legacy V2 and V3 SDKs are obsolete and not compatible with current versions of Unity. The last plugin version compatible with Orion V4 were the 4.4.0 Core Assets, these are no longer supported but can be found on GitHub if needed.

Click here for the latest releases of the Unity and Unreal plugins.

Version Unity Unreal
Leap Motion 2.x
Leap Motion 3.x
Leap Motion 4.x
Ultraleap 5.2+

¹ Not available on MacOS

² Meta headsets are not supported

³ Not available on Android 

Have more questions? Submit a request

0 Comments

Article is closed for comments.